Dropdown Menu Widget Update: 1.4.0

I made two updates to the dropdown menu widget.  Here are the updates:

  1. Fix IE display errors. This support is added using jquery. So it should work with every wordpress installation. Since IE doesn’t support hover pseudo class for li elements i added a simple javascript to add .hover class when you mouse over them. I tested it on my site with IE8 and it is working now. Not tested with older IE versions though.
  2. Second update is about wrapping menu items. As you see on my menu items with long text on it like “Dropdown Menu Widget” make menu large and some people don’t like this view. That’s why i added option for no-wrap. Now you can easily change this wrapping behaviour from your options panel. (Note: This behaviour is limited for certain themes only.)

And here is a list of things i want to add to the next versions:

  1. Support for WordPress 3.0 menu & navigation system,
  2. Theme edit screen,
  3. Visual theme selection,
  4. z-index option.

You can download the latest version of the dropdown menu widget here.

That’s all for now. If you like this plugin please support its development. Thanks!

You may also like my Subpages Plugin for wordpress. Check it out!



NS Weight Release